3

How do you configure TauDEM 5.1.2 to run in QGIS 2.10.1?

TauDEM plugin activated, and visible in the Processing Toolbox (Advanced Interface).

However, TauDEM tools do not run.

I get the message '"mpiexec"' is not recognized as an internal or external command, operable program or batch file.

NOTE: TauDEM DOES run from the command line interface (mpiexec is recognized).

System paths have been updated for MSMPI and TauDEM. OS is Windows 8.1' TauDEM 5.1.2 and QGIS 2.10.1 are each 64-bit installations (confirmed).

  • 1
    What have you done so far? please expand on your question; It is very general – Farid Cheraghi Oct 1 '15 at 12:55
  • 1
    Update: TauDEM plugin activated, and visible in the Processing Toolbox (Advanced Interface). However, TauDEM tools do not run. I get the message '"mpiexec"' is not recognized as an internal or external command, operable program or batch file. NOTE: TauDEM DOES run from the command line interface (mpiexec is recognized). System paths have been updated for MSMPI and TauDEM. OS is Windows 8.1' TauDEM and QGIS 2.10.1 are each 64-bit installations (confirmed). Appreciate any help. – oh10mike Oct 1 '15 at 16:40
  • 1
    Please include this information in your question – Farid Cheraghi Oct 1 '15 at 16:45
  • Encountering the same problem in QGIS 2.12.1 under Windows 7/64, I searched the Windows Registry for mpiexec, and found that there was no value under the key HKEY_CURRENT_USER/Software/QGIS/QGIS2/Processing/Configuration/MPIEXEC. By searching for MPIEXEC from the Windows start menu, I located the directory that contained it, copied the path to that directory, and pasted it as the value of the above-mentioned key. That fixed the '"mpiexec"' is not recognized' error. Unfortunately, it just unmasked another path problem, where TauDEM apparently can't find the elevation grid, even though I have fu – Terry Morse Dec 26 '15 at 9:52
  • Hi Terry, did you find a solution? I had the same problem. There was no "TauDEM command line tools folder" set within the Processing Options and well, I could not find the folder with the tools!!! So I had to download the tools again. Does QGIS seriously deliver the Processing Toolbox without the TauDEM Tools? – AndreasK May 3 '16 at 15:33
6

TauDEM appears as an option in QGIS's processing providers, but you still have to install it yourself, which is...unfortunate. The following worked for me:

System: Windows 7 64-bit, latest QGIS from the OsGeo4w installer (2.14 Essen)

  • Make sure the MS Visual C++ 2010 redistributables reccommended on the TauDEM support page are installed correctly - I had to remove and reinstall mine
  • Install the latest MS-MPI package, which is v7 at present - just google 'MS-MPI' and it should be result #1.
  • Install TauDEM from the source at -http://hydrology.usu.edu/taudem/taudem5/downloads.html. You'll have to provide a name and email to access the windows installer. That will also install a couple of things if you don't already have them, notably standalone GDAL - just roll with it.

In QGIS, open the Processing Options dialogue where you can enable TauDEM. Set the following options:

  • MPICH2/OpenMPI bin Directory: C:\Program Files\Microsoft MPI\bin
  • TauDEM command line tools folder: C:\Program Files\TauDEM\TauDEM5Exe

your folder locations should be pretty much identical to the above, maybe with minor differences. Setting those paths in QGIS should be identical to editing the registry keys mentioned above directly in regedit.

Restart QGIS and then test one of the tools, you should be good to go.

0

Please reinstall the HPC package under Administrator account. Here is some help from the TauDEM's author: http://hydrology.usu.edu/taudem/taudem5/support.html

  • 1
    Why should reinstalling help? The problem with "mpiexec" has obviously something to do with the file path. – AndreasK May 3 '16 at 15:20
0

I've had the same problem trying to run TauDEM 5.3 on QGIS 2.14.3 (Assen) (on a 64 bit windows 7). Even though mpiexec and taudem folders are in the system path I had the message: "mpiexec is not recognized as an internal or external command, operable program or batch file".

Then, reading the comments to the original post I saw the suggestion by Terry Morse, who manually included the MPIEXEC folder to the Windows Registry Key. This worked, but "unmasked" another problem with TauDEM unable to find the elevation grid.

At that point I checked the windows registry again, and noticed that the TAUDEM_FOLDER key had empty value as well. So I pasted there the path to the TauDEM folder, and, after restarting QGIS, everything started working fine! I have no idea why this worked, but it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.