4

I use topology checker and add a rule that polylines must not have dangles. It find errors for all 36 polylines but I think some topologies are correct at the right side. Can you help me how can I fix this. Because I tried same rule in ArcGIS and results seems better. Pictures are below.enter image description here

enter image description here

  • I have the opposite result where QGIS picks up actual errors that ArcGIS misses... might be worth exploring the errors you think are WRONG in QGIS as they might actually be correct! – DPSSpatial Oct 1 '15 at 15:00
  • but when I zoom to the points in qgis I do not see any dungles – user51044 Oct 1 '15 at 15:07
  • 1
    First, the word is dangles. Second, are there any vertices along that vertical line that all your horizontal lines are snapped to, or are they just snapped to the edge/line itself? If they don't share actual vertices I can see it failing a topology check - especially if the tolerances are different between the two programs. – Chris W Oct 1 '15 at 19:38
  • Yes, they don't share any vertices I think it fails – user51044 Oct 2 '15 at 13:55
4

ArcMap and QGIS may be using different snapping tolerances. It's worth checking what each value is.

ArcMap - Geoprocessing - > Environments... -> XY Resolution and Tolerance will show you the current resolution and tolerance values. http://resources.arcgis.com/EN/HELP/MAIN/10.1/index.html#//001w0000000r000000

QGIS - Settings -> Snapping Options... will show you the tolerance for each layer. http://docs.qgis.org/2.8/en/docs/user_manual/working_with_vector/editing_geometry_attributes.html?highlight=tolerance

| improve this answer | |
  • ı think it is not about tolerence values because I draw directly polylines in QGIS while snapping is on but same errors occured – user51044 Oct 1 '15 at 16:11
  • There is a tolerance setting in QGIS Topology checker but it seems totally useless. In my case I have checked for spatial overlaps within one layer and i got tons of errors which can not be reproduced even when zoomed in to the maximum level! Tolerance was set to up to 100m ... – hilpers Dec 1 '16 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.