4

I have been using happily QGIS for about 6 months, in the last week it has suddenly got much slower when generating an atlas using print composer.

I am running QGIS 2.10.1 on a PC laptop (Windows 7, core i7 2.4GHz with 16GB RAM).

The projects I've been working on have about 10-15 shapefiles (100-200MB each) and around 10 print composers.

Rendering in the main screen doesn't seem to have been affected but as soon as I try and generate an atlas from one of the print composers (even for only one atlas feature) everything is greyed out and 'not responding' for at least 20 minutes. This occurred even when I set up a simple project with 5 shapefiles and one print composer with one atlas feature.

I've tried uninstalling and re-installing qgis but clearly didn't manage a clean re-install as the recent file list is still populated (also, it made no difference to performance). I find it hard to believe my projects can be stretching the limits of the software or my computer to this extent. The one thing I did recently change was I installed the mmqgis plugin but uninstlling had no effect on the reduced performance.

Has anyone had a similar problem with the print composer? and have suggestions as to how to fix it?

  • I have the same problem since update to 2.18, tried to put files in one location, but still very slow (very, very slow...) Does anyone have the same iusse? – user16032 Jul 11 '17 at 8:29
3

I think I have solved the problem by looking carefully at the location and use of qml files. Prior to my performance issues, I reorganised some of my shapefiles but didn't do anything with the qml files. Having now moved and renamed the qml files to the same location (and name) as the shapefiles, the performance is much better.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.