I recently upgraded QGIS by building QGIS 2.11 from source against GDAL 2.0 on my Ubuntu 14.04 system. After a few teething troubles I got it to compile using QT creator. I now find that I can't open any spatialite databases e.g. openstreetmap with the error being returned:

obsolete libspatialite: connecting to this DB requires using v.4.0 (or any subsequent)

When I check it appears that QGIS was built against SpatialLite Version 4.1.1 so not really sure what has happened here. I can connect to all of my old spatialite dbs using the DB Manager in QGIS which allows me to view the attribute tables (but no previews). If I try and 'add to canvas' from DB Manager I get an error message telling me to check the logs with the following output:

dbname='/home/dori.osm.db' table="dori_buildings" (geometry) sql= is an invalid layer - not loaded

Equally I can explore the data with the QSpatiaLite plugin but if I try and load the data from the plugin into QGIS I get the following error:

Impossible to Load table 'dori_buildings' into QGIS

Anyone have any ideas what's happening here - did I miss out a dependency when building perhaps?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.