3

I use data driven pages to produce several maps. In the end product, all maps should show point data on a Country of europe.

So far the country is shifting around each time I change the data shown in the map. However, I want the country to stay in the middle of the map when I export the maps with a scale of 1:750'000. I tried all Options in the Data Driven Pages Set Up (best fit, Center and maintain current scale and data driven scale).

What settings do I have to use so that the Country will stay in the Center of the map? (I work with ArcGIS 10.2.2)

Below an example of what I mean

enter image description here

  • Which FC do you use to define the pages? The data you are editing? If so, try making a new (polygon) FC that you use to define your pages, preferably with a "Scale" field. – Martin Oct 7 '15 at 10:12
  • I am using the Point data to define the pages. If I make a new polygon FC, wont the DDP then ocus on the new polygonFC attributes instead of going through the different attributes of the Point FC? Or how do you mean it exactly? – user3476078 Oct 7 '15 at 12:31
  • 1
    Since you're using the Point data to define the page, each page will center on the point rather than the country. If you want to zoom to each country, try specifying the country as the layer for each page. – John Oct 7 '15 at 12:57
  • As the point data is the data which I want to be shown with data driven pages I have to select this Point layer as the layer for each page. The Country layer has no attributes, it is just used as a Background Illustration. Or do I understand something completely wrong? – user3476078 Oct 7 '15 at 13:58
  • You don't have to use the points as ddp-layer only because you want to display them. You can use any layer that (preferably) coincides with your points' extent. And in your case there's no surprise that the pages move when you move your points, since you have defined that your page should be centered around them. – Martin Oct 7 '15 at 14:25
2

I have a trick that worked when using a surface layer. Not sure if it will work with points.


  1. Set up the extent you want in the map/layout
  2. Open the "Set Up data Driven Pages" and chose the panel extent
  3. Choose "Best Fit margin"
  4. Choose "Specify using Page Units"
  5. Set up a margin Size that exceed anything that can reasonably fit according to the paper size (for a 210mm x 297mm paper choose 10 000 mm for instance)
  6. Enjoy the "Best Fit" algorithm silently failing and your extent preserved

Unfortunately I just checked and the "Best Fit Option is disabled when working with Point layer. So I guess you can trick ArcGis even more by converting your points to small circles using buffer tool, so that "Best Fit" option will be available.


Alternatively you can also use QGis instead.

1

Here's something I use for Data Driven Pages, it might be pretty basic compared to other options but it works in a pinch.

  1. Make a new polygon shapefile in the shape of a rectangle edited so that it has no fill and a solid outline.
  2. In data view place your shapefile so that it surrounds the area you want in your map.
  3. Open attributes and set up new columns for scale and rotation. Set the scale to match the desired map scale and use rotation to denote horizontal or vertical etc.
  4. In the DDP set up, set the layer, id, rotation, and spatial reference to the corresponding columns in the shapefile's attributes table.
  5. Make sure the size of the shapefile matches the scale of the map when you switch back into layout view. This might involve some measuring and math on your part. (i.e. in layout view, measure the dimensions of what your printed map will look like and go from there. for example: for a scale of 1:750,000 you may need a rectangle measuring roughly 312k x 197k meters).
  6. When you refresh the DDP, it should align itself with the shapefile. If you sized the shapefile correctly you should be able to just see it (depending on how thick your line width is) along the edge of the map. You can then turn the shapefile layer off so that it doesn't show up in the layout view. the DDP will still align to it.

This may seem tedious if you need several maps, but I've found it easy to copy and paste the shapefile and rotate/move it to your needed spot instead of trying to find a point to base the DDP on or drawing a new shapefile for every map. If you set the "sort field" in DDP settings to the shapefile ID, arcmap should make new page for every new shapefile that you make.

  • 1
    I use the same technique as well. Worked great when I put together a strip map series for a water trial, where segments varied greatly in length and had drastic differences in scale and direction/rotation.Great answer! – cl3 Oct 7 '15 at 16:07
1

My workaround would be this...
Create a polygon that matches the extent you want.
Do a spatial join on the polygon with the points table to get a polygon for each species type.
Use the polygon as the ddp index layer.
Use the points layer and enable page definition select the show matching. All points with the same species will show on the output.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.