0

I need to access ST_StraightSkeleton() function. At the moment i have a Postgresql
instalation PostgreSQL 9.3.4 compiled by Visual C++ build 1600, 64-bit installed via EDB with Postgis 2.1.7 on a windows machine that seems not have SFCGAL installed.

1st What would be my chances of having SFCGAL installed on this installation ?

2nd I'm willing to make a fresh install of another PostgreSQL / Postgis installation (built-in with SFGCAL) if that is less effort, but im a bit confuse on which installations and the order of installation for the .exe files at Postgis site below

http://winnie.postgis.net/download/windows/pg93/buildbot/

EDIT 1:

enter image description here

1

If you can wait we are planning to release 2.2.0 today. It has SFCGAL extension.

If you want to give it a try now, download the postgis 2.2.0dev windows binaries.

You'll need to use postgis 2.2. Since can't have both postgis 2.1 and 2.2 loaded in same database and postgis_sfcgal functions are in the postgis 2.2 dll.

CREATE EXTENSION postgis VERSION "2.2.0dev";
CREATE EXTENSION postgis_sfcgal VERSION "2.2.0dev";
  • thanks , i took the risk :-) downloaded postgis-pg93-binaries-2.2.0devw64gcc48.zip unzipped and copied to my postgres folder installation overwriting all files there . Uninstalled old postgis extension from all my db's . Now when trying to install the postgis 2.2.0dev it fails with the error at EDIT 1 – Jorge Vidinha Oct 7 '15 at 18:21
  • Any idea why this could be happening ? – Jorge Vidinha Oct 7 '15 at 22:06
  • Just got released. I'm building the windows binaries now and hope to have PostGIS 2.2 bundle windows installers out by next week or week after (which will also include pgRouting 2.1 and ogr_fdw). postgis.net/2015/10/07/postgis-2.2.0 – LR1234567 Oct 8 '15 at 5:41
  • Jorge, I'll check and see what could be up here. First of all, you might want to upgrade to 9.3.9. 9.3.4 they might have changed some things. – LR1234567 Oct 8 '15 at 5:47
  • Forgot to add, if you want to be more up to date, use 9.4.4 instead of 9.3. My production systems all use 9.4 currently, so I tend to test that more than the older versions (which I only test at release time). and as soon as 9.5 EDB binaries are out, I'll be building binaries for 9.5 – LR1234567 Oct 8 '15 at 5:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.