I have a basemap w/ GPS points on it, and polygons of certain areas. The polygons fall well within the borders of the basemap. I am trying to generate a Euclidean Distance map of distance to these polygons, with the ENTIRE basemap as the Processing Environment. The problem I keep running into is that the Euclidean Distance generates a map that only covers the absolute (x,y) extent of the polygon files. I have tried setting the processing extent as the entire basemap, converting the polygon file to a raster with the basemap as the extent.....to no avail.

How do I generate a Euclidean distance map that goes beyond the input feature extent?

  • Kind of a workaround, but why don't you try just modifying your polygon layer to have the extents you wish to see in the output?
    – Thomas
    Commented Oct 7, 2015 at 21:01
  • I tried setting a new extent (geonet.esri.com/thread/15671), but got error codes 010244 (could not set the analysis mapping window. Distance mapping is failed) and 010067 (error in executing grid expression) when I tried Euclidean distance.
    – Charlie
    Commented Oct 7, 2015 at 21:23
  • Okay never mind all that then. See my answer below.
    – Thomas
    Commented Oct 7, 2015 at 21:27

2 Answers 2


Geoprocessing functions like that can often be constrained to the OUTPUT EXTENT environment setting.

See this resource for ArcGIS 10. http://help.arcgis.com/EN/arcgisdesktop/10.0/help/index.html#//001w00000009000000

All you need to do is set the OUTPUT EXTENT to the desired extents.

  • I've tried that to no avail. I get the same errors as above. I've tried to set the extent to the basemap, and by manually entering bounding coordinates....
    – Charlie
    Commented Oct 7, 2015 at 23:23

This resource for ArcGIS 10 will give you all the information you need, but it's a little confusing if you aren't working on a stand-alone script. http://help.arcgis.com/EN/arcgisdesktop/10.0/help/index.html#//001w00000009000000

You can also modify the processing extent for all geoprocessing tools while working in ArcMap by going to "Geoprocessing > Environments" to open the environment settings. Then, under processing extent you are able to specify exactly what the processing extent should be.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.