1

I am trying to access a WFS from geoserver in QGIS, and when I load it, it comes in very strangely:

enter image description here

I can access it directly from the postgres database and it comes in fine. I'm wondering if there are settings to the geoserver layer I can adjust so that it comes in properly? WMS comes in ok, except when zoomed to full extent not all the features draw, in areas where there are a lot of polygons (it is a parcel layer with @ 170K records). When I zoom in on the WMS, the feature draw. But I'd really like to figure out what is going on with the WFS. I've also tried to load in feature for a limited extent with the same result.

5
  • Can you see if it's an issue with rendering? I've seen this a couple times on Windows PCs when "Render layers in parallel using many CPU cores" is activated, or "Feature Simplification" is enabled for that layer.
    – SaultDon
    Oct 7 '15 at 23:17
  • Thanks for the reply. Where can I find those settings? The feature simplification one sounds familiar but I just checked the layer properties and I don't see it.
    – kflaw
    Oct 7 '15 at 23:20
  • I did find that feature simplification option checked under the data store, I unchecked that option but the data is still loading the same way.
    – kflaw
    Oct 7 '15 at 23:29
  • A few questions come to mind: What does GeoServer report as the layer's SRS? What is QGIS using for the CRS? Finally, what's the WFS url that you are using?
    – bosth
    Oct 7 '15 at 23:37
  • QGIS and geoserver CRS both 3857. The url is 52.24.37.126:8080/geoserver/Iada_workspace/ows? and I am trying to load in the parcels
    – kflaw
    Oct 7 '15 at 23:47
2

I do not know the main reason but the GML from the service has some odd coordinate values:

http://52.24.37.126:8080/geoserver/Iada_workspace/ows?service=wfs&version=1.0.0&request=getfeature&typename=Iada_workspace:parcels&maxfeatures=100

gml:coordinates xmlns:gml="http://www.opengis.net/gml" ts=" " cs="," decimal=".">-1.295840489020236E7,5410000.64865586,0 -Infinity,-1.295837966400454E7,5410000.48182336 0,-Infinity,-1.295837994378932E7 5409958.2865818,0,-Infinity -1.295839798043889E7,5409958.40587354,0 -Infinity,-1.295840516987279E7,5409958.45341379 -1.295840489020236E7,5410000.64865586,0

It looks like your data have XYZ coordinates with all the Z values of "-Infinity". Perhaps that makes problems for QGIS. Because you do not seem to know real Z I would have a try by converting parcel polygons into XY geometries and publishing these 2D parcels as a new feature type.

1
  • Thank you for your answer, that was it. I stripped the z and m values from the layer and now it loads just as it should.
    – kflaw
    Oct 8 '15 at 23:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.