I'm new to using GIS software. I obtained two different sets of data:

  1. Topography data (raster, .asc)
  2. Bathymetry data (shapefile, .shp, etc)

I include topography data using Add Raster Layer and bathymetry data using Add Vector Layer in QGIS. (See attached figure) QGIS with raster and vector data

Is there any possible way to interpolate both different data sets like this? I have done some diggings, but they are mostly discussing how to interpolate vector layer data. I would like to get the water depth and land elevation in the same file after interpolation either in .xyz or .grd, so that I can use this as a computational domain for my simulation model.

  • You can convert your raster to points then use the GDAL grid in QGIS, this will triangulate the sparse points and interpolate to a continuous raster -or- add some points at the far edge, use GDAL grid then insert your known raster into the interpolated raster (more fiddly but the existing raster wont change). – Michael Stimson Oct 8 '15 at 5:32
  • @MichaelMiles-Stimson Is the QGIS GDAL grid in Raster - Analysis - Grid (Interpolation)? In my raster, those nodes without data are set to be -9999. In this case, should I extract those nodes with land elevation (positive value) manually, like writing a simply program to do it? – Kiat Oct 8 '15 at 6:05
  • -9999 sounds like NoData, if so then remove those ones... start editing, select by attributes and then delete (don't forget to save). There's about 3 different grid/interpolation tools I've found in the latest version of QGIS, I use the command line one but have a go with all 3 then pick the one that looks best; you will still have the original data and any results you don't like can be deleted then try again a different way. – Michael Stimson Oct 8 '15 at 21:41
  • @MichaelMiles-Stimson After selecting the Grid (Interpolation), I opened a shapefile as the Input file, chose Depth as Z field and chose .ASC as Output file. There are three interpolation algorithm as you mentioned, and I picked Nearest neighbor. Resize and Extent were unchecked. After clicking OK, a message popped out saying ERROR 6: GDALDriver::Create() ... no create method implemented for this format.. I tried following this link, but the command prompt console disappeared. – Kiat Oct 14 '15 at 10:57
  • Try creating the output as GeoTiff or ERDAS IMG then when successful convert to ASC. Some drivers don't implement Create() but rather are implemented in CreateCopy(), these two formats' drivers definitely implement Create() (I've used them in C++ and know that they're there in all versions of GDAL I've worked with) – Michael Stimson Oct 15 '15 at 5:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.