4

I converted the polygon layer to a line layer using the "Polygons to Lines" tool. Then I used the "Split" function of the Networks plugin. What I need to do next is to remove identical lines that were shared boundaries of the touching polygons.

I've tried using the MMQGIS plugin and v.clean (break, snap, rmline, rmdupl) but nothing works. You can see more details in the attached image.

Edit: you can download shapefile here: https://drive.google.com/file/d/0B25RJIaeA41SVmNOUndWWGNlWU0/view?usp=sharing

enter image description here

4 Answers 4

5

From the Processing Toolbox, run the tool with the suspiciously same name as in MMQGIS: Delete duplicate geometries:

Processing toolbox

Tested this and it reduced the attributes from 525 to 431.

Delete duplicate geometries

Hope this helps!

1
  • @ZoranPetrović - Awesome buddy, glad it worked :)
    – Joseph
    Oct 8, 2015 at 12:23
2

An other way is the processing toolbox.

Go to Processing menu > Toolbox. It opens the Processing Toolbox. Here, go to Geoalgorithms > Vector > General tools > Delete duplicate geometries.

1

The MMQGIS plugin has a "Delete duplicate geometries" option.

Install it from the plugin manager.

1
0

I just ran into this issue myself trying to bring MOD IV parcel data into cad as lot lines and ROW.

Step 1. Take your parcel SHP and convert to line. Vector -> Geometry Tools -> Polygons to Lines.

Step 2. Explode your Lines Processing Toolbox -> Explode Lines

Step 3. Now your Delete Duplicate Geometries will work. Before it would not recognize the polyline overlaps since they were only partial, but now you have simple lines which now have direct overlaps.

Processiong Toolbox -> Delete Duplicate Geometries

and there you have it, no overlapping lot line boundaries, ready to bring onto your plans.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.