1

We have a Geoserver serving a number of WMS layers from a PostGIS backend. Two are polygon layers with a content.ftl defined for getfeatureinfo requests.

These two randomly but rather often fail to show in the same info-popup.

The logs say

ERROR [freemarker.runtime] - Template processing error: "Expression feature. is undefined on line 7,.. in content.ftl

-- The thing is that it shouldn't be undefined and it isn't most of the time and never when there's just one of the two layers in the map.

The content.ftls are similar, both beginning akin:

<#list features as feature>
<table cellspacing="0" border="0">
<tr>
<td>Designation: ${feature.designation.value}</td>

i.e list features as feature, do ${feature.column.value}.

Could this be some sort of timings issue?

  • Have you ever solved this problem? – Benedek Simo May 18 '16 at 9:17
  • Benedek: Yep..it was suggested to try a newer Geoserver, tried one of the later 2.8 versions and the same layers with the same ftls worked without a hitch. – David I Nov 4 '16 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.