1

I've made a simple tool that accepts three parameters: an input file (feature class), an output folder (folder), and an output name (string). These are all required input with no filters. The tool's main description correctly displays on the right pane of the tool window in Arc, but the input parameter descriptions are not showing up when their fields are clicked on. I tried editing the Item Description in ArcCatalog, but this only brings up an empty window with nothing to edit. What am I missing here?

This is the tool's Help window

The tool executes successfully.

Ideally I'd like to be able to access/edit documentation completely within the script, but I don't know how to start there. This is all saved within a .xml file somewhere, right? If so, where is that stored?

EDIT: I'm using ArcGIS 10.2.2 for Desktop. Also, in case it's relevant, I made this tool by making a new toolbox (.tbx), right-click -> Add -> Script... And I browsed to my .py file.

#!usr\bin\python

import arcpy, os, csv

# Read the parameter values:
infile = arcpy.GetParameterAsText(0)
outfolder = arcpy.GetParameterAsText(1)
outname = arcpy.GetParameterAsText(2)

if outname[:-4] != '.csv':
    outname += '.csv'
# etc...
  • 1
    First of all good on you for doing this, not enough people document their tools, so +1 for doing this. Do you have some bespoke style sheet set? In ArcCatalog go to customize >options > metadata tab, set it to item description then restart the application? – Hornbydd Oct 8 '15 at 19:39
  • Oh! That was it! It was set to XToolsPro Metadata (XToolsPro hasn't even been working on my system). I changed it to Item Description, and now everything is there. Thank you! – Wassadamo Oct 8 '15 at 19:56
  • I would still appreciate an answer detailing how to access/use etc about the .xml files that support this item description. – Wassadamo Oct 8 '15 at 19:57
  • You can get to some of the metadata but not anything you have written for the parameters by simply running it through the Export Metadata tool. I tested this on a 10.2 setup, may be different for 10.3? Anyway that should be a separate question – Hornbydd Oct 8 '15 at 22:17
2

In the Item Description, you need to click Edit, then edit the description for different parameters. See picture below:

Decribing parameters for Arc tools

  • No, sorry I should've been clearer. When I click edit, the window is empty. Here is what I see. – Wassadamo Oct 8 '15 at 19:25
  • Interesting, even for a tool with no parameters at all I still get the item description to edit. – Nir Oct 8 '15 at 19:27
  • the blank window seems like a familiar issue. can you update your original post with your Arc version? – KHibma Oct 8 '15 at 19:38
  • Actually sorry, its not blank, you dont have the edit button. I see that now. Make sure the tbx is not read-only from windows explorer. – KHibma Oct 8 '15 at 19:43
  • @KHibma, I do have an edit button. Once clicked, it disappears and then that image is what I see. However, you bring up an important point...Could it be that my tbx is read-only? I made it here: Toolboxes\My Toolboxes\RichardTools.tbx – Wassadamo Oct 8 '15 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.