2

Using QGIS 2.10.1, if I open a table and then apply a filter using Layer Properties > General > Provider Feature Filter, the table view does not update. In other words, the initial list of records remains displayed in the table window. However, if I close and then reopen the table window the filtered records are correctly displayed.

Is this table behavior correct? I would expect that the table would automatically update after a filter is applied.

2
  • You can enter a filter at the bottom of the table which is applied dynamically. Oct 9, 2015 at 7:26
  • You are correct. However, that does not solve my original question: Filtering via Layer Properties does not dynamically update the table view.
    – Stu Smith
    Oct 10, 2015 at 0:12

1 Answer 1

1

This is a bug (or at least odd behavior) and should be reported in the QGIS Issue Tracker. However since it is an easy fix we can bypass this step and directly wait for the pull request to be accepted.

3
  • I don't know the difference between "issue tracker" and "pull request", but it appears that you have made the appropriate notifications via the pull request (thanks) so that it can be fixed in an upcoming QGIS release. I won't do anything further.
    – Stu Smith
    Oct 12, 2015 at 18:02
  • An "issue report" is the proper way to notify the developer team about problems (bugs) or ask for enhancements (features). A pull request is an implementation that fixes a problem or adds an enhancement and is just one click away from being included in the next release. Oct 17, 2015 at 18:14
  • Hmmm, almost eight years later (now at 3.28.8) and the problem still exists: an open table does not refresh when a filter is applied from the main page Layer panel.
    – Stu Smith
    Jul 5, 2023 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.