2

I have spatial data in ArcGIS 10.2.2 that I'm sharing as a Service and then viewing in ArcGIS Online. The data consist of the first and last name of employees, separated by a single space, i.e. 'John Smith'. Last names have been omitted in the example screen capture below representing the successful display of the data.

enter image description here

I would like to add a domain to a pre-populated field that constrains input into this field. The problem is that when I add this domain in ArcMap 10.2.2 and then share the result as a Service and then view it as a Map, the data itself no longer displays in ArcGIS Online.

Below is an example of the domain constraints. I have made certian that each name already present in the database is represented in the domain definition, to ensure that the issue is not that pre-existing data are not allowed within the new domain.

enter image description here

And finally, here is the result in ArcGIS Online when the domain above is applied to the Field of employee names.

enter image description here

Why might this be happening and what can I do to solve it?

Edit: To make this even more unnerving, I followed the advice of Adding a Field, setting the Domain, then populating via Field Calculator, and it still didn't work!

enter image description here

  • 1
    Agol is picky, bracket in alias might cause trouble. Try single field dataset, simple alias, might help to trace culprit – FelixIP Oct 10 '15 at 22:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.