0

I have a FME workspace and a workspace runner. The workspace reads several sources (PostGIS & Shapefile) but only one is batched. In other words, all shapefiles in one folders are all analysed against files from other sources, which remain the same on every run.

My problem is that the writer has a parameter "fme_basename" as the shapefile name value, but when I run the workspace runner, only the first shapefile gets the correct name (in this case L42213D) but the second is "NULL". Also all the rest of the batched files result as NULL so the second file is just overwritten until the process ends. This worked in my other workspace which was almost similar, but I can't get it working here...

closed as unclear what you're asking by BERA, aldo_tapia, nmtoken, xunilk, Vince May 10 '18 at 1:07

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

1

Im not absolutely sure what is happening in your workflow from your description, but try to set the properties of your reader in the child workspace to Merge Feature Type to Merge Filter = * , Filter Tye = Wildcard. See image below. enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.