3

I want to remove some nodes from a shapefile using QGIS 2.10.1

  1. I enable editing
  2. I click on the Node Tool
  3. I click on a node I want to select (it turns blue)

However, once I select this node I am unable to delete it.

The Delete Selected button is grayed out, as is cut, and pressing delete on my keyboard does nothing.

I assume I am missing something very basic but I can't figure out what it is.

  • How many nodes are in your feature? In 2.10 the behaviour was changed so that deleting nodes was blocked if it resulted in an invalid geometry. So eg you couldn't remove the last 3 nodes in a polygon. But this behaviour proved undesirable and has been reverted for the upcoming 2.12 release. – ndawson Oct 13 '15 at 21:56
  • It's a map of Canada so I assume deleting one or two nodes shouldn't result in an invalid geometry but it looks like that's what's happening. These were slivers inside a shape so my solution was ultimately to create a new polygon that overlapped them and then dissolve it into the main map. That solved the issue. – Max Hartshorn Oct 15 '15 at 14:14
3

I simply use the "delete" key on my keyboard. I just checked with the same version of QGIS and see the same thing you described: a single node is selected (highlighted in blue) but the "delete selected" button is grayed out. Using the keyboard does work even with the delete button inactive. If you select an entire polygon with the "select feature" tool the button becomes active.

  • Delete selected is for features, the delete button on the keyboard is for active nodes. – HeikkiVesanto Oct 14 '15 at 7:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.