1

I am trying to use the import multiple features into geodatabase option in ArcCatalog (ArcGIS 10.1). Or, similarly, I try to use the import raster option, which screen layout is similar to the multiple features screen, allowing you to import multiple rasters at once.

The process goes through with a green check mark, but when I expand the geodatabase, nothing is there, not if I refresh, not if I close the program and reopen.

If I use the option to import a single feature class into a geodatabase, it goes fine. That is what I have been doing as a work around. However, there is no such "import single raster" screen, so now I'm stuck as I need to import rasters.

Any ideas of what could be the problem and how to fix it?

I'm teaching a GIS course at a university, so am scratching my head about this problem, as my students are experiencing the same problem on their computers as well.

Here is the dialogue after it is finished--nothing unusual that I can note (used ~~~ to replace personal info here): Executing: FeatureClassToGeodatabase C:\Users\~~~\Documents\ArcGIS\Data\Canada\ontario_coastline.shp;C:\Users\~~~\Documents\ArcGIS\US_coastline.shp C:\Users\~~~\Documents\ArcGIS\~~~.gdb Start Time: Tue Oct 13 22:20:03 2015 Running script FeatureClassToGeodatabase... Completed script FeatureClassToGeodatabase... Succeeded at Tue Oct 13 22:20:03 2015 (Elapsed Time: 0.00 seconds)

And this is the output from the results menu from another attempt with just one file, but using the import multiple command:

enter image description here

  • 2
    What version of arc are you on? Are the computers current on the version service packs? – artwork21 Oct 14 '15 at 1:36
  • 10.1, and, yes, the service pack versions of Windows are current. – Cory A. Oct 14 '15 at 2:40
  • Please edit your question to add additional details that are requested using comments. I think you should go to Geoprocessing | Geoprocessing Options and turn off background processing as a test. It may give you more information about what is happening. You could also look at the Geoprocessing | Results window. – PolyGeo Oct 14 '15 at 3:06
  • Post edited, with more info; and turning off background processing did not affect the outcome. – Cory A. Oct 14 '15 at 3:27
1

I can't reproduce your issue with ArcGIS 10.3.1. Couldn't find a bug corresponding to it neither. As a workaround:

enter image description here

Batch and ModelBuilder can be used for rasters as well, if Raster To Other Format doesn't work for you. In ModelBuilder, use the Iterate Rasters iterator.

  • Thanks for these suggestions. I tried the Raster to Other format tool, with no success. Some outcome, which says it worked, but didn't. I worked on the model with the raster, but don't know ModelBuilder well enough to develop the same model you did (though got part way ). I could teach this later in the semester, but at this point, just need a way to import rasters into the geodatabase that does not involve teaching them something new at the moment. The issue seems to be, whenever I pull up an import window, if it is just a single import, then it works, if multiple, it doesn't. – Cory A. Oct 14 '15 at 22:04
  • @Cory A. What about using the tool in Batch mode, does it work? – GISGe Oct 15 '15 at 5:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.