I am trying to load a series of CSV files as vectors in PyQGIS. I run this code to try to get the first one:

uri = 'file://D:/Saved Stuff/gulags/1.40.csv?delimiter=;&yField=y&xField=x'
layer = QgsVectorLayer(uri, '1.40', 'delimitedtext')

Obviously it won't load when I run QgsMapLayerRegistry.instance().addMapLayer(layer). When I add the CSV manually to a map it loads fine. Here is what that looks like


AMURSKII ZhELEZNODOROZhNYI ITL;51.375889;128.134147;84053

BELOMORO-BALTIISKII ITL;62.912774;34.456850;78918

BIRSKII ITL;48.999752;132.461997;11634

Can anyone help me with this?

  • What happens when you do this? uri='file://D:/Saved Stuff/gulags/1.40.csv?delimiter=%s&xField=%s&yField=%s' % (";","x","y");
    – Thomas
    Oct 14, 2015 at 17:06
  • Still gives me false. The modulo is just a standin Oct 14, 2015 at 17:22

1 Answer 1


The problem was with your URI. (note the third slash)

Use the following as a working example:

uri = 'file:///D:/Saved Stuff/gulags/1.40.csv?delimiter=;&yField=y&xField=x'
layer = QgsVectorLayer(uri, '1.40', 'delimitedtext')

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.