1

I'm attempting to output streaming services on my ESRI Server install on Amazon Cloud but I am unable to.

My Service is successfully being published to server but when I attempt to view it using the default Java Script the stream service URL is red with the error Cannot Connect I opened the chrome development tool and found the error failed: WebSocket opening handshake was canceled

It seems like there is a port conflict between AWS and ESRI but I can't track it down. I do not have a firewall and I am not restricting any ports. And I know It is not a socket issue because I have bytes set to 1024000 in GeoEvent.

  • I think EC2 blocks most ports by default. I think you need to explicitly open them. In AWS manager, go to your ec2 instance, then click on the link under the security groups section. The Inbound tab should show what ports are open. Once they're open there, I think you'll also need to open them in Windows via the Server Manager>Tools>Advanced Firewall. – Kirk Kuykendall Oct 14 '15 at 18:37
  • They are open and I am testing locally (VNC in to the machine) – risail Oct 14 '15 at 18:59
  • A quick question, I created an account on AWS but how do I set up a Geoevent environment . Is there any documentation on how to start that? Please help!! Thanks Julie K – Julie Mol K May 18 '18 at 15:08
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – Kadir Şahbaz May 18 '18 at 15:33
0

The issue was caused by an SSL conflict. My RHEL 7.0 install on the AWS server was not done using an ESRI provided AMI because at the time of this writing the ESRI AMI does not work with LDAP enabled. In order to confirm if you have an SSL conflict configure your server with HTTP enabled only and publish a streaming service and confirm it is steaming data. Then switch to HTTPs & HTTP enabled and confirm that your HTTP stream still works. If you have an SSL conflict the https wss will not work

Solution: 1. Confirm all ports Geoevents will use on the server are available in AWS app 2. Confirm all ports Geoevents needs are available in the and not restricted by the OS's firewall 3. Secure Arc Server 4. Add Certs in Server Admin to the machine 5. Point ESRI to the new Cert in Admin 6. Add Web contextURL and websocket context url in admin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.