2

enter image description hereI am importing a CSV file into QGIS using the official instructions on their page: http://www.qgistutorials.com/en/docs/importing_spreadsheets_csv.html. For some reason, the x & y coordinates are showing up on QGIS in the wrong place. I have checked the coordinates in Google Maps and they correctly present the locations I want to see in Tanzania.

Can you please explain what I am doing wrong by reviewing the attachment.

enter image description here

7
  • I think the official instructions are from the QGIS docs itself but the tutorials by Ujaval Gandhi (which you linked) are indeed brilliant!
    – Joseph
    Oct 15, 2015 at 10:59
  • What CRS are you using when it prompts you for one? Oct 15, 2015 at 11:07
  • @Vesanto unfortunately, QGIS does not prompt by default.
    – AndreJ
    Oct 15, 2015 at 11:17
  • WGS 84 / Pseudo Mercator Oct 15, 2015 at 11:17
  • The coordinates in column B and C are in degrees, not Mercator.
    – AndreJ
    Oct 15, 2015 at 11:19

1 Answer 1

1

Under Settings -> Options, CRS tab, you can select that you want to get asked for the CRS of new layers by checking Prompt for CRS.

The data in your table seems to be in degrees, so EPSG:4326 might be the right one.

The Project CRS can be different from that. For backgrounds by the Openlayers plugin, EPSG:3857 is the best choice for that.

2
  • I've added the CSV file and it's showing the locations in the south of Spain. I don't understand! Oct 15, 2015 at 11:24
  • Have you mixed up latitude and longitude? The negative values of latitude should be Y, and the positive longitudes be X.
    – AndreJ
    Oct 15, 2015 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.