What happens:

1) Take a map with an image that was georeferenced earlier, which works fine.

2) Add a second image to the TOC and fire up the georeferencing toolbar.

3) Select the new, ungeoreferenced image from the drop-down list...

4) ... georeferencing on first image vanishes.

How do I georef the second image without losing the first georeferencing?

  • 3
    Are you updating the georeferencing on the first image before attempting to georeference the second? – Jason Bellino Nov 8 '11 at 17:02
  • @Jason No, I am not. The first has been done, and I do not wish it to change. – Tom W Nov 8 '11 at 20:57
  • Could you provide a little more information describing the exact names of the images you are working with and the directories in which they are located, etc ? – Jason Bellino Nov 8 '11 at 21:10
  • @Jason Sure. The mxd file lies in a folder called 'GIS'. The first image is at \GIS\tiles\Picture-combined0.bmp (the assoictaed .xml and .ovr files in the same folder). The second image is at \GIS\Area 6.bmp – Tom W Nov 9 '11 at 14:04
  • @Jakub I don't understand what you mean. – Tom W Nov 9 '11 at 14:04

Are you updating the georeferencing on the first image before attempting to georeference the second? This might throw ArcMap off a bit.

EDIT: I see now that you have an image with external georeferencing information stored in an .xml file, so this shouldn't be the issue.

I tried to duplicate your problem on my machine, but did not have any issues (at first). I was able to georeference one of the images below, update the georeferencing, and then georeference the other. HOWEVER, I deleted the external georeferencing information files and then tried once again, this time without updating the georeferencing of the first image and voi la, the georeferencing disappeared when I toggled to the other image in the toolbar.

I'm not sure why this is happening to you since you say that the georeferencing information for image 1 is already stored in an external .xml file. You might try to "rectify" your image before trying to process the second one to see if that helps.

I'm sure you've already seen the ESRI Desktop Help article on georeferencing, but if you haven't I'd suggest reading it.

enter image description here

  • I looked at the xml file, and this was the content: <PAMDataset> <Metadata domain="ESRI"> <MDI key="PyramidResamplingType">NEAREST</MDI> </Metadata> </PAMDataset> ... which implies it has nothing to do with the georef'ing. – Tom W Nov 9 '11 at 21:37
  • @TomW, are you re-georeferencing image 1 each time this happens? If so, make sure you hit "Update Georeferencing" in the georeferencing toolbar to save the information to a .aux.xml file. Once this is done you should be able to move on and georeference the next image. – Jason Bellino Nov 9 '11 at 21:59
  • No, I am not (or at least not intentionally). However, when I select image1 from the drop-down list, the "update georeferencing" and "rectify" options are greyed out. Further, when I go to the link table (as in link between pixel coords and map coords), the table is blank... it's like the georef'ing has disapeared, but Arc is still displaying it correctly! – Tom W Nov 10 '11 at 14:06
  • It sounds like there is a ghost in your image file! Maybe try to re-georeference it in place, update the georeferencing, then see if you can georeference the next image. – Jason Bellino Nov 10 '11 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.