I am trying to use the Near tool in Arc10 as described in Snapping points to a line using ArcGIS geoprocessing tools for the purposes of batch-snapping a feature class of points to a feature class of lines. The XY coordinates produced by the Near tool do not exactly map onto the lines - there can often be about a foot distance between the line and the new point. The new points also do not appear to be on the shortest-distance path from the original points. The projections are the same for the two feature classes and the data frame, but points are in meters while lines and data frame are in feet. In attempting to fix this problem, I have projected my original points into feet before using Near, with no change in the outcome. Any suggestions on why this method doesn't work for me, and how to get my points to batch-snap to lines, are greatly appreciated!

  • A quick test and meters worked - feet did have a mis-match of around 11" - so try projecting into meters do the near and test that with your data.
    – Mapperz
    Nov 9, 2011 at 15:13
  • Thank you for the quick test! I opened a new mxd and loaded only the 2 input files, and the Near tool worked like a charm! My theory is that there must have been some legacy phojection issue in the old mxd. Nov 18, 2011 at 15:38

1 Answer 1


This problem was resolved by opening a new .mxd and running Near tool there, see my comment above. Cheers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.