2

I'm trying to save some changes I made in a vector file (polygons) in QGIS 2.10.

The file contains properties and I want to merge two of them into one. I toggled and selected the two and then pressed enter image description here

But when I try to save my changes, I get an error message that says that it could not be saved. Export to vectorlayer failed. Object geometry not imported. OGR-error. This is my translation of the original message (Swedish).

It worked the first time I merged two properties and saved, but not when I try to do the same thing again?

QGIS doesn't crash, I just can't save my work.

I use Windows 8.

  • After merging, have you tried saving it as a new shapefile using the Save As... option? – Joseph Oct 16 '15 at 12:37
  • Yes, I tried that, but I still get the error message. – SoS Oct 19 '15 at 6:51
  • Perhaps save the shapefile (before trying to merge) as a new shapefile and see if you can merge features for this shapefile instead? – Joseph Oct 19 '15 at 9:21
  • Did you try to check permissions to QGIS folder ? Lets try to give a full access to QGIS installation folder and to the path where you save .shp files. – Artec Dec 15 '15 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.