I'm still having trouble with the dissolve tool and I've tried all of the solutions offered here including moving the process from the background and repairing the geography. I've also tried amending the spatial index and narrowing the dissolve area down considerably.

Is there anything that I'm missing?

Right now when I run the tool, it jumps right to 33% complete and stalls out. If I wait for an hour or so it gives me the 99999 error (edited to clarify, I am also getting the Invalid Topology error). I'm doing this project for work and waiting an hour each time isn't working for me (or my boss) anymore.

  • Perhaps "Invalid topography" really reads "Invalid topology"? ("Topography" deals with the elevation and local shape of the earth's surface whereas "topology" deals with the connectivity among geometric elements of coordinate-based descriptions of features. It's a good idea to read error messages carefully and literally, because subtle distinctions can sometimes carry revealing information.)
    – whuber
    Commented Nov 8, 2011 at 19:39
  • 4
    Maybe consider posting a screenshot of the actual error (for detail) and if you have the ability to share your data for others to test. Have you tried running your buffer on a small subset of features from your layer? Is it SHP, pGDB, fGDB? Does it work if you switch formats? Commented Nov 8, 2011 at 21:17
  • Thanks for the responses, so far, the only thing that has worked so far is to dissolve a bunch of smaller subsections which leads me to believe that I'm asking too much of the tool. I've also contacted support just in case there is something that they can do.
    – Erin
    Commented Nov 9, 2011 at 16:15
  • I would try testing with more RAM - upgrading from 4Gb to 12Gb has eliminated such stalling by Dissolve for me.
    – PolyGeo
    Commented Apr 2, 2014 at 12:54
  • If you have more than 4GB RAM you may also benefit by install x64 background processing (available from 10.1 and later) and enabling background processing in the geoprocessing options. Another tweak is to set the ARCTMPDIR environment variable to point to a writable folder (ie C:\TEMP) before starting ArcMap. (This fixes a known issue that can come up when running any tool that does topological overlay, DIssolve included.) Commented Nov 25, 2015 at 2:36

5 Answers 5


Assuming you are getting the "Invalid Topology" error you need to make sure that all geometry in this feature class is correct. Make sure the layer is in a File Geodatabase Feature Class format. Run the "Repair Geometry" then try DISSOLVE again.

Dissolve can create VERY large features from a large amount of small features and it can be a very memory intensive operation and thus take a very long time depending on the complexity of the input feature class and the dissolve parameters.

There are also other considerations when running dissolve explained in detail in the Dissolve Help and the How Dissolve Works.

When you feel that you have complied with all the usage requirements for the dissolve operation as outlined in the Help Usage article, you can submit a request for Support Assistance with ESRI. They have been very quick to respond lately. (within 24 hours) They will run the same steps on their end and provide you with solutions. You will need your ESRI customer number to request support.

  • 2
    +1. I love the "run"-->"ruin" typo near the end :-).
    – whuber
    Commented Nov 9, 2011 at 14:46
  • Honestly, not intentional... Had a good chuckle about that one. Commented Nov 9, 2011 at 15:10

Try copying it to an FGDB and run the tool. Maybe there are better chances when you run in an FGDB. Better Luck.


Just had a problem similar to the one described above. I used the buffer tool, but only buffered by a 1 inch, DISSOLVED FIELDS by "LIST" then I checked the field I needed dissolved. It worked like a charm with only a few topology errors. I know its an odd way to go about it, but it is works quickly!


I had the same problem with missing polygons. The shape-file was a result of the merge of 2 shape-files with 2 differet coordinate systems (this was the reason). I changed coordinate system of initial shape-files to the same and merged them again. This solved the problem.


I am not a member of this site but use it often. Was looking up this same issue. I was able to fix this and get it to work by moving the data into an FGDB and then running repair geometry and then I was able to run the dissolve on the data.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.