2

I have a QGIS (2.10.1) project that contains several shapefiles, all of which are EPSG:3338 (NAD83 / Alaska Albers). The project property CRS is also EPSG:3338. All of the shapefiles display correctly, and the project is to my liking.

However, when I subsequently add a basemap via the Web > OpenLayers plugin, the project properties are immediately forced to EPSG:3857 (WGS 84 / Pseudo Mercator), and the map display changes accordingly.

I do not want the map to display in Pseudo Mercator. How do I maintain the project's original NAD83 / Alaska Albers CRS while displaying an OpenLayers basemap?

Note that the project's "on the fly CRS transformation" setting has no effect. Regardless of its initial setting, it always will be checked on after adding a basemap.

6

You can't - the OpenLayers plugin only supports EPSG:3857, and doesn't allow reprojection. I believe this is to avoid breaking the TOS for the respective layer sources. I'd strongly suggest using the newer "QuickMapServices" plugin instead, as it can handle reprojection and works correctly with the Map Composer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.