2

I have a load of Irish grid references that I need to create a map of in Ireland - any advice? Tried to input a couple of refs and open in Biological record tool thinking this would be simple but hey ho, I'm asking for help now! See the CSV example - what am I doing wrong?

enter image description here enter image description here

  • Remove the letters in the coordinates (eg. E296351 should just be 296351). To add the csv file to QGIS, go to Layer > Add Delimited Text Layer... making sure the First record has field names option is selected. Define your point X and Y fields in the Geometry definition and pray it works :) – Joseph Oct 19 '15 at 14:10
  • Thanks Joseph - did try this also, but then I get issues with the fields, whereby the Northings also has 296351 in it, from cell B2? – SNA user1969 Oct 19 '15 at 14:19
  • You may need to clean up your csv file, the X and Y fields should only contain coordinates. – Joseph Oct 19 '15 at 14:35
  • Ok, so the cvs only has the numbers in, no letters or names, still the fields are field_1, coordinates in B1 and A2, or field_3. – SNA user1969 Oct 19 '15 at 14:55
  • and states that there is no data found in file... – SNA user1969 Oct 19 '15 at 14:56
2

From the screenshots it looks like you're on a Mac, using Excel. When saving a CSV from Mac Excel, you have to select the 'Windows comma separated' format instead of the first CSV option in the save-as list ... otherwise QGIS doesn't interpret the file correctly.

enter image description here

  • It's a super-annoying problem that loses me a little time every week! – Simbamangu Nov 13 '15 at 9:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.