3

I am a new user of QGIS and I am having a problem configuring a legend on the Print Composer. I am trying to remove the item text from a layer and then alter the text below hoping that this would compact the legend. Here is a screenshot of the Print Composer showing the legend and elements I am trying to alter:

enter image description here

The process I used was to select the layer --> click the pencil edit button --> delete all the text in the popup box. After I clicked OK I expected the text to disappear, but it doesn't. I think I'm missing something obvious?!

3

Hit the dropdown menu right to your layer name and select "Hiden" instead of "Subgroup".

Also if you want to compact the legend even more look for the spacing option below one the items properties pane.

  • MarHoff - worked a treat! Thanks for the swift reply :) – GLP Oct 19 '15 at 16:55
3

I believe you make sure auto update is turned off, then click on the layer you want to remove, then click on the red minus button. That will remove the layer from your legend.

Here is a great how to for QGIS legends: http://www.helenedraux.net/blog/improving-your-legend-qgis

  • 1
    This might not work in this case because he have a complex symbology on one layer and he want to hide the root. But deleting the root might remove the whole layer. Depend on version, can't check right now, maybe I'm wrong :/ – MarHoff Oct 19 '15 at 16:47
  • I gotcha, I was a little confused by the question. I believe you are correct, that changing the root will change the sub-layer as well. +1 for your answer then! – ed.hank Oct 19 '15 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.