1

In QGIS 2.8, the heatmap plugin got CRS broken. I updated to 2.10, now in the plugin the dialog is broken: it does not let you choose the format.

I render layers for atlases with heatmap style. But I need to export it to GeoTIFF, and I don't see a way to do this.

Updating the QGIS is not easy in Ubuntu, since it works normally when installed from a PPA, but installing from sources, or downloading debs is very painful.

Is there a workaround?

A command line example will do too.

edit here's a screenshot. The format list is empty, and if I write file extension manually as I did here, it still does not allow, showing a message that format is not chosen.

Screenshot: format dropdown is empty

Meanwhile in another dialog, format choice works correctly:

enter image description here

Versions: Versions enter image description here

  • I just opened 2.10 and output a heatmap raster (using the Raster→Heatmap→Heatmap… menu). The dialog allowed me to select the format. Can you provide more information or a screenshot, because I can't confirm your issue. – Lee Hachadoorian Oct 21 '15 at 12:59
  • Additionally, are you looking for advice on how to update QGIS on Ubuntu? I'm not sure what you mean by the remark, since it appears that you already have updated to 2.10. Do you mean that you installed but source but would rather use the package manager? – Lee Hachadoorian Oct 21 '15 at 13:01
  • @LeeHachadoorian see the screenshot in the question. I installed it from PPA (ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu). – culebrón Oct 21 '15 at 18:10
2

I am running QGIS 2.10 on Linux Mint 17.2 (based on trusty), and in the Heatmap plugin the available formats dropdown is not empty, so your problem is not a general problem with QGIS running on LM/Ubuntu. I'm not sure how to reproduce this problem.

However, you suggest that the issue arose after an update to 2.10. It occurs to me that a significant amount of QGIS functionality (esp. for plugins) is dependent upon python-qgis. This could explain the difference between Heatmap (plugin) and Raster Calculator (which I believe is core), so I would check that you have python-qgis that installed with

apt-cache policy python-qgis

and install it if it is missing.

Another concern is that you say that you updated to 2.10 from the ubuntugis-unstable PPA. However, as far as I can tell, ubuntugis-unstable only goes up to version 2.8. Not sure why this would lead to incomplete functionality. Maybe you have QGIS 2.10 but python-qgis 2.8? The discrepancy does imply that you may not have installed from the repository that you intended.

If you are running Ubuntu Trusty, I would recommend installing 2.10 from the QGIS repository, but begin by purging your current installation:

sudo apt-get purge qgis python-qgis

Then add the following lines to /etc/apt/sources.list:

deb http://qgis.org/ubuntugis trusty main
deb-src http://qgis.org/ubuntugis trusty main

Note: although you can edit /etc/apt/sources.list directly, in practice I prefer to use the Software Sources tool (available standalone or from the Synaptic menu) to add new repository source lines.

After doing that, update and reinstall qgis and python-qgis packages via Synaptic or:

sudo apt-get update
sudo apt-get install qgis python-qgis qgis-plugin-grass

These instructions taken from http://qgis.org/en/site/forusers/alldownloads.html#debian-ubuntu. I can also confirm that they work, as that is how I got QGIS 2.10 installed on LM 17.2. This is also the instructions for the version designed to work with ubuntugis dependencies, and requires the use of the ubuntugis-unstable PPA, which you are already using. But if you are using a more recent Ubuntu release than Trusty, you have to pick the appropriate version, and not use ubuntugis dependencies. Check the link for further instructions.

  • I checked, the version was 2.10.1 and python-qgis: Installed: 1:2.10.1+20trusty, then reproduced all the steps, it installed without issues, and unfortunately, there's still the same problem with heatmap dialog. I launched qgis.bin from shell just to see if there are exception messages, but there's nothing. – culebrón Oct 22 '15 at 1:04
  • Reinstalled gdal-bin the same way, still no effect. – culebrón Oct 22 '15 at 1:09
  • Sorry, it was a stab in the dark. Might be worth posting to qgis-user mailing list. – Lee Hachadoorian Oct 22 '15 at 3:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.