1

I created a file GDB with various feature classes that already have data in them. I then set up a domain to the GDB, and when I open the attribute tables of each of my feature classes there is no-drop down to choose from the coded domain. I also tried adding a new field within the attribute table and there is still no coded domain. Is this because my feature classes were pre-populated with data?

7
  • 1
    did you try, saving , closing and opening catalogue/ArcMap again?
    – yanes
    Commented Oct 22, 2015 at 19:40
  • 1
    Did you Start Editing?
    – PolyGeo
    Commented Oct 22, 2015 at 19:40
  • Yes, I added a new field. Then started an edit session. Commented Oct 22, 2015 at 20:16
  • I also tried saving, restarting ArcMap...also tried restarting my computer and none seem to work. Commented Oct 22, 2015 at 20:16
  • 1
    Since the gdb already has data, you might try setting it up in a blank feature class first and then importing your data. To speed this up you could create a schema from the existing FC.
    – Drew Smith
    Commented Oct 22, 2015 at 21:16

1 Answer 1

1

It seems you did something wrong.please follow my example step by step:

  1. Create a Domain in GeoDatabase [Step1][http://i.imgur.com/kZQml4e.jpg]1
  2. Add Filed in your layer(target) Right-click on Layer and select properties in Geodatabase when opened feature class properties Select Filed Tab and add new filed name and choose type of field (exactly same domain type)[step2][enter image description here]2
  3. Open layer attributes, right-click on layer in table of content and select open attribute table, after that add new field. [Step 3. in other way][enter image description here]3
  4. when open attributes is still open start editor, Finally you can see code values is dropping down for new filed, they are code value you entered in step 1, [Step 4][enter image description here]4

Note that the domain entry might not appear if the target field is not of the same data type as the domain.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.