I am having serious problems in exporting a map (Google satellite map) linked to QGIS.

Using the print editor I clearly see the part of the map I want to print and also in the right scale, but when I save it as jpeg, the result is: the correct map in a circle in the middle of the page, and all around it seems that Qgis is zooming at different scale on another part of the map [see attached file].

Any suggestion about it ? I don't want to save it as simple screenshot because I need an HD file.

![enter image description here]1

  • several threads on this subject and the fact that it is very buggy and not recommended ... Commented Oct 22, 2015 at 22:36
  • Hi @mapBaker, do you have any recommendations to obtain a correct jpeg exportation using opensource satellite view ? thanks
    – Carmelo
    Commented Oct 22, 2015 at 22:51
  • As a new user please take the Tour to learn more about how this site works.
    – PolyGeo
    Commented Oct 22, 2015 at 23:30

2 Answers 2


Use "QuickMapServices" plugin rather then OpenLayers. I'd never recommend that anyone uses that OpenLayers plugin anymore, it's just too buggy.

This contains one fairly high 'open satellite' layer - the Mapquest Open Aerial layer:

enter image description here

..and when used in a print composer export, displays quite accurately without any artifacts or mis-alignments:

enter image description here

  • Thanks for your help ndawson ! I tried before using Mapquest, but it seems it has zoom limitations. Wherever I tried it (Europe or China), at a scale 1:200,000 is fine but if I want to zoom in (1:100,000) the symbol of the grey photograph appears. I checked my internet connection too, but it is quite stable ! Thanks again
    – Carmelo
    Commented Oct 23, 2015 at 9:15
  • I am sorry to add that the exportation process is not working. The jpeg coming from the print composer is just grey with the "picture-missing" logo on it. I am afraid also that there is a kind of connection with my area of interest (Shanghai), not such an open-source friendly area maybe !
    – Carmelo
    Commented Oct 23, 2015 at 9:36
  • MapQuest Aerial only has high resolution for the US. "Global coverage is provided at zoom levels 0-11. Zoom Levels 12+ are provided only in the United States (lower 48)." From: d3noob.org/2014/02/using-mapquest-open-aerial-tile-server.html Commented Oct 23, 2015 at 10:29

This imagery dataset works for me too - the ESRI World Imagery. Follow link below, run script in Python to add raster layer:


  • Welcome to GIS SE! As a new user please take the tour to learn about our focused Q&A format. Please include as much information as possible in your answer, using any links as reference. Links can change or disappear without warning which can leave the answer with no information. You can edit your answer to add as much info as possible.
    – Midavalo
    Commented May 1, 2017 at 17:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.