2

I cannot get QGIS's (2.8.2 Wein/Win 7) georeferencer to work for the life of me. I select points, set the CRS, run the function, before http://i.imgur.com/lsQUOU3.jpg

and the output looks like this. after http://i.imgur.com/pGgoBlF.png

Blank on the map, set to 0 to 0 in the red band and blank in the others in Layer properties (hitting Load changes these values, but apply does not change the screen and the changes are not maintained after I close the properties window), but a garbled thumbnail of the original image still appears. Zoom to layer does not change the display location. Original image in .jpg.

I've seen bug reports for this (or similar) issue stretching back to 1.8 but never any resolutions. Where am I going wrong?

edit: Andre, using your method produced the same result, unfortunately. I cannot seem get a useable image out of the georeferencer, even with adjusting the stretch values, unloading/reloading, et c.

geo http://i.imgur.com/VyZCu5T.png

map http://i.imgur.com/NC2v239.jpgg

  • Have you tried converting the original image to an alternative format, perhaps a tif? I don't know if it's a bug but it's one thing that I sometimes try when I'm having issues with georeffing images. – Ed Rollason Oct 23 '15 at 13:55
  • unfortunately reproduced the error using a .tif – Bryce Oct 23 '15 at 17:35
  • What transformation settings are you using? For two-point georeferencing I normally use Helmert/Linear. This needs a good, undistorted scan or image. – nhopton Oct 24 '15 at 12:19
  • linear in this example, but i've gone as a high as 15 tie in points with the same results – Bryce Oct 28 '15 at 16:15
2

You only have two GCP points in your list. With that little information, the Georeferencer can not work.

Try to grab as much points as you can identify across the whole picture.


Update

I was successfull with a part of your screenshot and these settings:

enter image description here

enter image description here

  • my understanding was that two points would work with a linear transformation (see above), but i've also used many more points and other transformations with the same results – Bryce Oct 28 '15 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.