1

I'm having a problem when trying to render a shapefile's labels that has Greek characters with the use of truetype and I'm getting weird characters. The code for my label section is as follows:

LABEL TYPE truetype FONT arial SIZE 12 COLOR 50 50 50 PARTIALS FALSE ENCODING ISO-8859-7 END

I've also tried to use ENCODING GREEK or even WINDOWS-1253 and UTF-8. But always getting weird letters.

  • Are you sure your Arial variant has the glyphs? – lynxlynxlynx Oct 23 '15 at 20:40
  • Yes. The alias is arial and the glyph is "Vera.ttf". fonts.list file and glyphs are in the same folder. The FONTSET in my mapfile is set to: FONTSET "/usr/share/fonts/truetype/freefont/mapserver-fonts/fonts.list" – Stefanos Oct 23 '15 at 20:56
  • If the font is ok, my guess would be the data was corrupted (pe. saved with a different encoding without conversion). Did you get just the shape file or also accompanying files (one contains the charset)? – lynxlynxlynx Oct 23 '15 at 21:16
  • Which one contains the charset? I think my files are OK (the folder contains: .dbf, .prj, .sbn, sbx, shp, shp.xml and .shx). I experimented by making my own shapefiles and saving them with different encoding. Specifically I tried ISO-8859-7 and WINDOWS-1253. I also tried "greek" encoding but it was saving the shapefile with encoding ISO-8859-7 which I had already tried. – Stefanos Oct 23 '15 at 21:26
  • Could you make a small zipped shapefile with just a few features for testing? – user30184 Oct 23 '15 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.