1

My drawing file (.dwg file) is contained with Annotation with Gujarati Text in many type of fonts (e.g. Gujarati Saral, Nilkanth, Shruti...). After conversion of annotation to shapefile, attributes are seen in undefined characters.

So how can I get the same result in a shapefile?

Is there any process or solution to visualize the annotation characters in an attribute of shapefile.

[Tried to convert in ArcMap from an attribute table > Properties > Appearance, which is temporary to see the characters]

Attachments:

1) Drawing File - Annotation Characters

enter image description here

2) shapefile - attribute table (Seen Undefined Characters)

enter image description here

  • Welcome to GIS SE! As a new user be sure to take the Tour to learn how our focussed Q&A format works. – PolyGeo Oct 27 '15 at 7:39
  • I'm dealing with the same problem, and it seems the way autocad handles the shape fonts is very complicated... – Davide Jul 19 '16 at 14:55
  • I'm not sure if this tech article by ESRI is relevant to your case but it is worth having a look support.esri.com/technical-article/000013192 – Techie_Gus Jul 19 '16 at 16:13
  • @Techie_Gus Yes, this article refers to encoding of attribute table using the cpg file which is an optional file used to specify the code page for identifying the character . CPG: webhelp.esri.com/arcgisdesktop/9.3/… – Shiko Jul 20 '16 at 4:12
2
+50

A possible solution to your problem is to do the following:

  1. Create a Personal Geodatabase file (.mdb) in a directory
  2. Load the DWG file into ArcMap
  3. Right-click the layer that you want to export a feature class -> go to Data -> Export data -> Under Save as type: choose File and Personal Geodatabase Classes
  4. Navigate to the personal Geodatabase file that you create in step (1) -> double-click the mdb file -> save the file here
  5. Open the attribute table and check if the fonts correctly displayed.

The reason to do the above process is that shapefile format (.shp) does not support unicode by default, but geodatabase does, as you can find in this FAQ: Does ArcGIS Desktop support Unicode?

Another solution if the above one did not work is that you may need to change the language settings under windows, if you have Gujarati language installed. In that case you need to go to Control Panel -> Region and Language -> Administrative -> Change System Locale. Select the correct language. You may need to restart your computer to update the changes in your system. Then, load the geodatabase file into ArcMAp and open the attribute table. Check if the characters were adjusted or not.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.