I'm using ArcGIS 10.1 (SP1 for Desktop) and when I'm exporting my attribute table to a dBase format, it will export some but not all the rows. There is no error message indicating anything has gone wrong. I only notice it when I'm opening the table in Excel. I've been experiencing this issue with several different tables (each of varying sizes from 10 records to 300000) and this problem doesn't happen every time. The example I'm going to show is with one of my larger tables.

Here are my steps for exporting an attribute table (with my selection already completed): Table Options > Export > Selected Records > Choose Location > Name > dBase Table > Export

This is my attribute table. I need to export 174230 rows. enter image description here

My exported table gave me 51125 rows. This is what my exported table looks like: enter image description here

After my several tries, I was finally able to export the full table. I had to put a definition query on. Sometimes, I get around the problem by doing the standard copy and paste. This depends on the size of the table I'm working with.

I know there are workarounds, but this problem is quite persistent. Has anyone experienced this problem? Is there something wrong with my settings?

  • See GIS Stack Exchange answer here. Although it is not the exact topic (deals with importing) it does discuss record limitations of different ESRI technologies. There should be relevant information for you there. – GeoSharp Oct 27 '15 at 17:13
  • 1
    How many attributes does a record have? How large are the file sizes you're working with? What version of Excel are you using, and does it support the number of rows you're trying to export? Have you tried exporting just to a csv? I would suggest trying the Table to Excel GP tool but you don't have that available at 10.1. Have you tried using an intermediate step, like creating new feature class/shapefile out of the selected records, and then attempting to export their attributes? – Chris W Oct 27 '15 at 18:46
  • Environment spatial extent might be a reason – FelixIP Oct 28 '15 at 5:36

What about right click then copy selected then paste them in your excel file enter image description here

  • This doesn't work well when I have really large selections like the one above. However, for smaller tables, this is definitely worth a shot. Thanks for your help! – user61359 Oct 27 '15 at 18:27
  • have you tried using Copy Rows (data management) tool . select the features then use it – Ahmad saleh Oct 27 '15 at 19:25

Check if it is a memory issue by having Windows Resource Monitor On when you do it. I seem to recall I had this issue, and it resulted from lack of memory. I think I fixed it by doing something to allocate a chunk of hard drive to act as a cache(?) or swap (virtual memory) for ArcGIS. This page talks about how to increase the size of the 'pagefile'. In any case, the term refers to the way your computer uses the hard disk as ram when it runs out of ram. I have mine set to 12 gigs.

  • I thought it was a size issue originally too, but I've had the same problem for tables with less than 5000 records total too. I'll keep that in mind though. Thanks for your help! – user61359 Oct 27 '15 at 17:58
  • Try it without anything else running. Multiple pages of Chrome can eat memory quickly. – Mox Oct 27 '15 at 18:00

Another solution to get all the records will be to open the ArcMap and export the selected records to a separate personal geo-database not a file geodatabase and then open with Ms Access database to view the table.You will the copy your table to a Ms excel spreadsheet, all the records will be available.

Not the answer you're looking for? Browse other questions tagged or ask your own question.