5

I've been using QGIS 2.10 for a few weeks and have just started trying to export maps using Map Composer. This might be a very common question with a trivial solution but I just can't figure it out. For some reason, the map grid and coordinates aren't correct, and I cannot find anyway to fix them.

In the image below, I have created a plot of an example bathymetry raster with a grid that is using map units (both project and raster are in UTM 24S CRS), and an interval of "5" for both X and Y.

I have also inserted a distance scale with "1 maps units per bar unit" and a fixed width of "50 map units".

I have measured objects using this scale and it seems to be correct. Unfortunately, it completely disagrees with the map grid coordinates. I am very connfused with this, and mystified by how I can fix this.

Also notice that the grid coordinates start at zero on the lower-left corner. This is also completely wrong. Also don't know how to fix.

enter image description here

4

When you are in the properties for the map (Item Properties pane when the map area is selected), when you are adjusting the grid (after expanding the 'Grids' dialogue box), there is a drop-down menu called 'Interval units' where you can select 'Map Unit'(which is what it sounds like you want), 'millimeter', or 'centimeter'. Tested this in a map of my own, and changing to centimeter gave me something similar to what you've got.

(This is all within the Print Composer window for your map).

Here's a screenshot, highlighting that part of them menu. Screenshot showing where to select the units for the border coordinates

  • Weird, yesterday I tried this.. Today it's working! Thanks! – jhc Oct 28 '15 at 12:52
1

I also experienced the same problem for quite sometime with nothing seems to solve it despite trying many things suggested in the Internet. It turned to be the setting/ value for the 'Interval units' and 'Interval' in the screenshot above that play the trick. Try this:

Set the 'Interval units' to 'Map unit' and then for 'Interval' (both the X and Y) value, try key in '0.1' or '0.01' or any smaller numeric value until you see the coordinates appear on the map composer. Of course, you may try with other numbers than 1 such as '0.05'. The value '1.000000000' given in the screen shot example above covers a very big area of the map (tens or hundreds kilometres) across that it won't be visible for a small area. This is evident as can be seen in the scale of the map above where the total length of the scale is only 200 m (50 to 0 m plus 0 to 150 m) and the map is only about 400 m across. Hope this solves the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.