3

In my stand-alone QGIS app I am using vrt files of DTED rasters. All vrt files are build with the same Python code and have the same structure, codepage etc. I use them for display only.

<VRTDataset rasterXSize="121" rasterYSize="121">
  <SRS>GEOGCS["WGS 84",DATUM["WGS_1984",SPHEROID["WGS 84",6378137,298.257223563]],PRIMEM["Greenwich",0],UNIT["degree",0.0174532925199433],AUTHORITY["EPSG","4326"]]</SRS>
  <GeoTransform> 4.0995833333333330e+001, 8.3333333333333003e-003, 0.0000000000000000e+000, 2.7004166666666666e+001, 0.0000000000000000e+000,-8.3333333333333003e-003</GeoTransform>
  <VRTRasterBand dataType="Int16" band="1">
    <Metadata>
      <MDI key="STATISTICS_MAXIMUM">1401</MDI>
      <MDI key="STATISTICS_MEAN">1000.386039205</MDI>
      <MDI key="STATISTICS_MINIMUM">818</MDI>
      <MDI key="STATISTICS_STDDEV">97.464262339239</MDI>
    </Metadata>
    <NoDataValue>-3.27670000000000E+004</NoDataValue>
    <SimpleSource>
      <SourceFilename relativeToVRT="1">DTED/E041/N26.dt0</SourceFilename>
      <SourceBand>1</SourceBand>
      <SourceProperties RasterXSize="121" RasterYSize="121" DataType="Int16" BlockXSize="1" BlockYSize="121" />
      <SrcRect xOff="0" yOff="0" xSize="121" ySize="121" />
      <DstRect xOff="0" yOff="0" xSize="121" ySize="121" />
    </SimpleSource>
  </VRTRasterBand>
</VRTDataset> 

It happens, that some vrt files get changed in the way, that the line <GeoTransform>...</GeoTransform> is deleted! And sometimes in the lines beginning with <MDI the decimal dot is changed to a comma. Both happen independently from another.

This is true for only some vrt files, but when it happens then always the same files are affected. I pasted the missing line back into the vrt files (or build them new), and after some QGIS ups and downs, the same effect takes place.

I am having this problem with QGIS 2.8.2 on CentOs 7 using German language settings. Any ideas what's going on here? Or what additional information I should supply to find a solution?

2

Following environment variable solved the problem:

export LC_NUMERIC="en_US.UTF-8"

Btw this also solved a problem with spatial queries against SpatiaLite databases, where in sqlite3_prepare statements a mixture of decimal point and comma occur.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.