1

When editing a feature class stored in Oracle Spatial, I am receiving 3 warning messages upon stopping the edit session:

enter image description here

There are 2 more after pressing OK - PROJECT_POINTS and PROJECT_POLYGONS.

I wanted to see if it would happen in a File Geodatabase and a Shapefile, so I saved copies of the original data in those formats and tried to start then stop editing. The FGDB throws up the same messages as above while the SHP does not.

Has anyone seen these messages before and can explain them to me or direct me to more information about them. I'd like to resolve the issue entirely but the data seems to be holding onto some reference even after saving as a new file.

Update 1: I've contacted esri support. If I find out an answer through them, I'll share it here but they seem baffled by this as well.

1

I decided to create the feature classes PROJECT_POINTS, *_LINES, and *_POLYGONS to one of the GDBs to see if I would get the same warning messages. I added them to a clean MXD along with the highways file from the original database that was throwing the warning messages. I started an edit session then stopped as before. This time, I received a new message stating that I needed to rename the new layers. When I renamed them to match the new message and tried again, I was able to start and stop an edit session with no warning messages.

After some discussion about this, we decided that it might have something to do with our upgrade from 10.1 to 10.3.1. We have a machine that was not updated and discovered there was a custom Add In that was built for 10.0 and still worked in 10.1. We were able to trace the issue to that Add In and once I removed the reference to it within my registry editor, everything worked as it should.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.