0

The tiger schema must be added to the database search path for the functions to work properly.

I just started recently to use tiger dataset and postgres database and I have basic understanding of both. I would like to fix the following:

loader_generate_census_script: command not found

closed as unclear what you're asking by John Powell, Chris W, PolyGeo Oct 29 '15 at 21:40

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    It would be helpful to include more information about the steps you've taken to arrive at that error. – Chris W Oct 29 '15 at 21:13
  • @Chris not sure how to clarify this any better! are you familiar with how to install postgis & tiger dataset, postgis_tiger geocoder? – mehany Oct 30 '15 at 1:53
  • No, I'm not, which is part of what you could add to clarify - the steps you took to install them, or at least a link to the instructions you followed. The current answer states it should have been done automatically with proper installation. Knowing the steps you took may point out the issue/solution. – Chris W Oct 30 '15 at 19:55
2

Hmm well if you installed with

CREATE EXTENSION postgis_tiger_geocoder;

It should do that automatically for you unless your user has an overriding search_path.

Anyrate standard way is to do:

ALTER DATABASE gisdb SET search_path="$user",public, tiger;

Note the settings don't take affect until you reconnect to the database.

Not the answer you're looking for? Browse other questions tagged or ask your own question.