I have a set of polygons in ArcGIS 10, which I want to label. Despite setting the Unplaced label icon to "on" and using an expression for the label (so that all objects should be labelled), not all objects are being labelled, whether using the standard label engine or Maplex.

I have tried reloading Arc, creating annotations, creating a new feature class, but nothing works. Has anyone else seen this behaviour?

There is a similar question How to "Never Remove" labels in Maplex? but this seems to be a slightly different issue - I can't even get the labels to show up as unplaced.

The screenshot below gives some more context - I would expect all the yellow regions to have a black or red (denoting unplaced) A, but they don't.

Screenshot showing Maplex options

  • 1
    Try using the standard labeling engine instead of Maplex; that seems to work quite well when attempting to label all features. Any chance some geometry is invalid (negative area and such)? Nov 14, 2011 at 15:12
  • sorry, didn't see that before my last comment. Think it was geometry related, can't explain it though. Standard label engine didn't seem to make a difference
    – Stev_k
    Nov 14, 2011 at 15:22
  • I also had the same problem. Repair Geometry worked for me as well. Thanks to all who replied. ArcToolbox -> Data Management Tools -> Features -> Repair Geometry
    – user20488
    Jul 26, 2013 at 20:06

2 Answers 2


Two things:

  1. In the label position tab (using mapplex) try using the fixed position setting.
  2. Also in your annotation fc if you open the attribute table, start an edit session, then change the status to placed.

If that does not help then another idea is:

  1. create xy values for centroid,
  2. export as dbf,
  3. then re-load as XY event, and
  4. label the points without symbology for points.
  • The first point makes no difference, and re the second point, the only features in the annotation tables are those features which have been labelled by the label engine - i.e. no unplaced labels are included. It's all quite strange
    – Stev_k
    Nov 14, 2011 at 14:52
  • hmm - very strange indeed. if you export the table (maybe just the fields causing trouble), can you see those values in a txt file? (thinking of special poblems like utf8 or strange formatting.)
    – Brad Nesom
    Nov 14, 2011 at 15:03
  • 1
    another idea. create xy values for centroid, export as dbf, then re-load as xy event, and label the points without symbology for points. ??
    – Brad Nesom
    Nov 14, 2011 at 15:04
  • That worked - I guess it must have been something to do with the polygons - very bizarre though. Thanks for the idea. Arc does seem to be very tempramental with labelling, which is strange.
    – Stev_k
    Nov 14, 2011 at 15:14
  • Another NOTE is tha tif you have values with <NULL> value you can see the layer have problems labeling.
    – Brad Nesom
    Oct 5, 2012 at 17:53

I had this same problem - not labeling each feature.
The solution appeared simple - just run Repair Geometry on problematic feature layer.
Then everything is displayed correctly.

  • Repair geometry worked for me as well when my labels were showing up strange locations.
    – kkaszas
    Sep 9, 2014 at 19:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.