5

I'm new to QGIS and trying to deal with on the fly reprojection. I have three layers :

  • a shapefile in EPSG:4326
  • a raster in EPSG:3395
  • that same raster reprojected in EPSG:3857 (with QGIS via the "Save as..." contextual menu available when right clicking on the layer. I manually set the right extent in the options)

I want to show them in QGIS in EPSG:3857 and EPSG:4326. The three layers' CRS are set correctly in their properties window.

If I set the project CRS to EPSG:4326, the shapefile is shown correctly but the rasters are not (they are not visible at all).

If I set the project CRS to EPSG:3857 :

  • the shapefile is correctly displayed
  • the original raster is show at the right place, but not entirely (seems like the on the fly reprojection is not reprojecting the extent correctly) -> see screen 1
  • the reprojected raster is displayed correctly -> see screen 2

If I set the project CRS to EPSG:3395 :

  • the shapefile is correctly displayed
  • the original raster is displayed correctly
  • the reprojected raster is show at the right place, but not entirely (again, seems there is a problem with the extent)

Does someone know what's happening here? Is there any way to have everything displayed correctly in EPSG:3857? Is that normal that QGIS is unable to reproject (on the fly) from EPSG:3857 (and EPSG:3395) to EPSG:4326?

Screen 1 (shapefile and EPSG:3395 raster, the raster is cut): enter image description here

Screen 2 (shapefile and reprojected raster, everything OK): enter image description here

7

The Save As ... option only works good with vector layers. For rasters, use Raster -> Projections -> Warp.

The mercator projections are not able to display the North and South poles (they are in infinity). So if your shapefile includes +/- 90° N/S, the mercator raster files might go bananas.

  • Thanks, I'm testing the Projections menu, it will probably take a while. There is no problem with the poles, my raster don't have data there (as you can see on the 2nd screenshot, where all is correctly displayed). The problem is on the east / west sides, where the raster get cut (as you can see on the first screenshot). – Tim Autin Nov 2 '15 at 10:25
  • Is On the Fly projection turned on? It looks like it's off by default per the QGIS 2.14 documentation. – smiller Mar 5 '18 at 19:10
  • @smiller if you have two layers with different CRS, OTF gets enabled automatically. – AndreJ Mar 6 '18 at 6:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.