2

I am trying to transform a GeoTIFF EPSG:4326 +proj=longlat +datum=WGS84 +no_defs and a GeoTIFF EPSG:31982 +proj=utm +zone=22 +south +ellps=GRS80 +towgs84=0,0,0,0,0,0,0 +units=m +no_defs both to EPSG:102020 +proj=laea +lat_0=-90 +lon_0=0 +x_0=0 +y_0=0 +datum=WGS84 +units=m +no_defs

Command used:

gdal_translate -a_srs "+proj=laea +lat_0=-90 +lon_0=0 +x_0=0 +y_0=0 +datum=WGS84 +units=m +no_defs" -of GTiff "source path" "target path"

Results:

The target file for EPSG:4326 seems to be in the right place, but in wrong scale (pixel size unchanged). The target file for EPSG:31982 seems to be in the right scale, but in wrong place.

I already tried the following commands:

gdalwarp -overwrite -s_srs "+proj=longlat +datum=WGS84 +no_defs" -t_srs "+proj=laea +lat_0=-90 +lon_0=0 +x_0=0 +y_0=0 +datum=WGS84 +units=m +no_defs" -r near -multi -of GTiff "source path" "target path"

and

gdalwarp -overwrite -s_srs "+proj=utm +zone=22 +south +ellps=GRS80 +towgs84=0,0,0,0,0,0,0 +units=m +no_defs" -t_srs "+proj=laea +lat_0=-90 +lon_0=0 +x_0=0 +y_0=0 +datum=WGS84 +units=m +no_defs" -r near -multi -of GTiff "source path" "target path"

Both results seems to be in wrong place and wrong angle (rotated).

How to solve this geotransformation with GDAL?

  • How do you determine that they are rotated/wrongly transformed and it isn't an issue with the display options of your GIS? – Kersten Nov 2 '15 at 10:24
  • 1
    Gdal_translate is wrong tool for you, -a_srs does not do anything else than write given parameters to the target file. If it was EPSG:4326 in the beginning after applying the LAEA paremeters with -a_srs it is still an EPSG:4326 image but with wrong metadata. Cases when -a_srs can be used are a) source image is missing srs metadata but you know what it should be and b) source image is having wrong srs metadata but you know what it should be. – user30184 Nov 2 '15 at 10:35
  • So, my need isn`t a translation but a reprojection! My problem is solved. I checked the metadata and it is not "+lat_0=-90 +lon_0=0" but "+lat_0=-15 +lon_0=-60". Thanks for the explanation. – João Lucas Lara Rodrigues Nov 3 '15 at 9:49
1

As stated by @user30184 in comments, gdal_translate won't reproject the raster. The a_srs parameter is useful to write correct coordinate reference system to files when they are not defined or are incorrectly defined within metadata:

-a_srs srs_def: Override the projection for the output file. The srs_def may be any of the usual GDAL/OGR forms, complete WKT, PROJ.4, EPSG:n or a file containing the WKT. No reprojection is done.

On the other hand, gdalwarp does reprojection but you were setting the source spatial reference set (i.e., the -s_srs parameter) with incorrect values as acknowledged in this comment.


Defining a CRS (SRS) versus reprojecting it is a classical FAQ in GIS. For example, in GIS SE: Layers with same coordinate system should align/overlap in ArcMap but do not?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.