1

I have created what I thought to be a simple ModelBuilder model and the final output (.shp format) is always an empty. As you will see in the ModelBuilder image below:

  1. Merged 3 track logs now called TrackMerge
  2. Buffered the newly created merged file, TrackMerge, with a 500 meter buffer. It is now called BufferOutput.
  3. I performed an intersect of the BufferOutput.shp with 3 separate polygon shapefiles that are in a folder or Workspace called WeedTracksMergeScript. I did this by using the Iterate Feature tool. I did this by selecting the Workspace called, WeedTracksMergeScript. I gave it a Wildcard name of *Infest because all of the file names that I wanted to be iterated began with Infest.
  4. The output below is simply called Outputs.shp

enter image description here

I've tried numerous renditions of this and have not been able to make the final Intersection of the 3 additional shapefiles with the shapefile BufferOutput.shp. I've tried skipping the Iterate feature tool and feeding the 3 shapefiles directly into the Intersect tool to intersect with BufferOutput.shp and the output has also been empty.

I know the BufferOutput.shp intersects with the polygon shapefiles in the particular file or Workspace called WeedTracksMergeScript. I have visually inspected this to make sure these shapefiles intersect the BufferOutput.shp.

Can anybody point out what I might be doing wrong?

1

Have you run the intersect outside of model builder? The blank output file suggests you might have a coordinate system issue, with some of your files in different geographic coordinate systems. Do all your files have a defined coordinate system?

What setting do you have on the intersect? There are multiple options, and you may not be using the one you expect. If you want to select any intersection polygons, you might use 'Select By Location' instead. Or if you only want the part where they intersect, you might try 'Clip' instead.

Is there a reason you can't do the merge and buffer outside of model builder? As you currently have the model designed, it will re-run the merge and buffer for each iteration, which will make the model take longer to run.

0

Thanks! I ended up using the Clip tool and then Merged the infestation polygons into one shapefile. For all intents and purposes, the model works.

Once it worked, I tried using the Iterate Feature Classes tool on my initial inputs on the model, while giving it a T* wildcare to only iterate through the shapefiles beginning with a T in the selected workspace/folder. The final output came out empty again. Any thoughts on why the iterator won't work as opposed to directly inputting the shapefiles into the Merge tool?

  • Are you using 'make feature layer' in your model? Anytime you add a shapefile to a .mxd, it creates a layer, and the shapefile gets projected by some default coordinate system. When you are using modelbuilder, that process doesn't occur, so you have to manually create the layer, using the 'make feature layer' tool in modelbuilder. – Mox Nov 4 '15 at 23:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.