1

I recently encountered the following problems with a shapefile in QGIS 2.10.1:

  • when I simply tried to save the layer as a new layer, there is error message: "Feature geometry not imported (OGR error: )".

  • when I tried to do some processing with the layer, for example, to intersect it with another layer using the "intersection" algorithm from the processing toolbox, it finished without error, but the resulting shapefile does not show up on the map. Actually, in the attribute table there is 0 feature.

The shapefile displays the zip code of a country and it shows correctly on the map. But it seems whatever processing with it leads to an error. Any idea why this happens and how to fix it?

I attached below the link to the shapefile so that you can play with it to see the problem.

shapefile

  • 1
    I suggest you to make your Shapefile (or a subset) available on Internet, so that others can replicate the problem and see what is happening with the data. – Germán Carrillo Nov 3 '15 at 0:51
  • 1
    I attached a link to the shapefile in the post. Thanks for any suggestions and help! – epomqo Nov 3 '15 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.