-1

I'm trying to geocode by city and country name in CartoDB, and several city names are coming up either false or null. I know that this has previously been an issue with the cities not being included in Geonames. The cities are Beijing and Rome. I'm using the "Georeference by city names" option and choosing my city column and country column (see attached image). I know I can just add coordinates for these, but I'm not sure why it's not working! I double checked in Geonames to make sure I"m using the version of the name considered a "populated place". cartodbtable

  • Could it be possible that it's returning a false or null based on too many matches? I went to the Geonames webpage and all of those returned multiple entries (same country, multiple entries) except for Ljublijana, which did not seem to be included in their database. – MaryBeth Nov 3 '15 at 21:04
  • @MaryBeth CartoDB tries to find always the best match, or at least a single match by using the place with the biggest population – iriberri Nov 6 '15 at 17:01
  • @user61753, I'm sorry but I'm unable to replicate the problem with your new information. Could it be possible that you have some empty spaces/line feeds in the city names or in the country names? Here's an example of my table with Rome + Italy geocoded: team.cartodb.com/u/iriberri/tables/rome_italy_dont_delete/table – iriberri Nov 6 '15 at 17:04
2

I just made a quick test in this table here and everything worked except for "Ljublijana", which is expecting "Ljubljana" instead.result

The cities available under the CartoDB geocoder are (right now) those ones categorized as "Populated places", which can be found in Geonames by the white P icon: icon

Could you please rephrase your question by sharing the dataset that you are using and the options you are selecting in the geocoding form?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.