3

I use Google aerial photos when using QGIS (2.10.1) using the openlayers plugin.

I find that it is very slow, and often hangs when I refresh or move around the map.

Is there a way of improving its performance - I am certain it is not my internet connection, which is fibre optic.

  • In Settings > Options > Rendering, there are options to enable render caching, utilising maximum CPU cores and you can set the map update interval. Perhaps play with these options? – Joseph Nov 5 '15 at 12:05
  • Thank you. I've just given it a go. Render caching was already set, but I've ticked the multiple cores option. It hasn't made an obvious improvement. – Jo Pedder Nov 5 '15 at 14:48
1

You could try to add the layer as a raster as described here:

Alternative to OpenLayers plugin for QGIS?

Or use the quick mapservices plugin: https://plugins.qgis.org/plugins/quick_map_services/

Perhaps loading the layer this way can speed things up.

0

The projection can make a difference to rendering time. Try setting the map projection to the map tiles' native projection, generally Psuedo Mercator (EPSG:3857).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.