2

I've been using QGIS for quite some time, but have encountered a problem that I can't seem to resolve. I am georeferencing an aerial photograph. I have established ample GCP points. After a fresh install of QGIS on a particular computer, the georeferencer works perfectly and provides the correct output. After the initial run, the georeferencer fails to work on any dataset, always returning the error message "Failed to compute GCP transform. Transform is not solvable." Picking new GCP points has no effect whatsoever. Changing images has no effect. The georeferencer works for the first run on any computer, and then quits. I tried re-installing QGIS, but the problem persists despite the new installation. It seems to me that QGIS is holding on to some temporary data that is crashing the georeferencer application. Any ideas?

2

I had this problem for a while, uninstalled and reinstalled QGIS several times, but actually turned out to be an easy fix, I unchecked the 'Set Target Resolution' in the transformation settings window. My work doesnt require a target resolution so was an easy work around however, I'm still not sure what the route of the problem is.

  • My "set target resolution" is already unchecked – Pertinax Mar 19 '18 at 18:42
1

I experienced the very same problem today with same error message. After many frustrating attempts I finally figured out: Not enough space on external HD where computed raster was supposed to be saved.

0

Check the encoding of your point coordinates in column DEST X & DEST Y.

-1.67022e is NOT exaclty -16.702208, but that's what got saved, so just check for errors there.

If you see some entries that look strange like the one above, deselect them then re-save your point file with a new name.

Go ahead and rerun Georeferencing. It should work smoothly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.