1

When we do extract by mask in ArcMap results always shows some area difference in raster outputs.

We are using clip layer as vector and layer to be clipped as raster DEM.

Our area of interest is irregular vector boundary but when we extract those areas from raster DEM, the output(extracted DEM) area will not matching with actual vector area we used.

How can we solve this problem?

2

It is highly unlikely that your raster area will ever exactly match your vector area by the very nature of rasters.

You vector polygon boundary will cross through your raster cells. When extracting by polygon, Arc uses the center of the cell to determine if a cell is to be included in the output. If the center of the cell is inside the polygon, the cell will be included and, if the cell center is outside, the cell will be excluded. The raster cells are not sub-divided. Their size if fixed by the raster resolution. The more convoluted your boundary, the more edge cases there will be.

There is therefore no way to guarantee that the raster area will exactly match the vector area (even when rasterizing a vector polygon). However, you can bring the results closer by using a finer resolution of raster.

0

If I am correct, you are seeing differences not explained by differences only at the edges of the raster. If the cells of your input and output rasters don't line up, you need to set a Snap Raster in your Environment settings. For working with rasters in spatial analyst (or any raster output), you typically want the output raster to match the input raster, otherwise you may have a different number of total cells in the output. Specifically you want to set this under the Processing Extent section (see screenshot) but you also likely want to set the cell size (you can just put the original layer in for that value so it is exactly the same as the input). The snap raster will ensure that the cells line up with the input and will also result in the same number of cells for every "Extract by Mask" performed using the same input and mask. It could be that this was not standardized on your inputs (zoom in and compare your raster inputs to see).

Screenshot

EDIT: So I thought it might help if I add some more context to what I suspect is the problem. If your input rasters are not aligned, this could create the problem you described. If the input rasters are aligned and the clip feature layer is the same, there is no logical explanation for differences in area (except maybe a software bug?). See the "cell alignment" screenshot. You can compare your input rasters by zooming in close enough to see individual cells and turning the topmost raster off and on while looking at the intersection of cells (e.g. like where the red dot is in my screenshot). If the cells don't line up perfectly, you will assuredly have differences in the area of output.

cell alignment

  • dear Sir thanks for reply. Even though we set processing extent,snap raster and cell size extract by mask analysis always resulting some area difference from input boundary. this may be due to raster cells (this has cell size, we can't cut as we need this is always square in shape. may be true? – Pradeep Balan Nov 13 '15 at 5:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.