2

I have the following issue:

There is a postgis table that contains a geometry column of type multipolygon (epsg is 4326, if it's relevant).

This layer is exposed via geoserver. When I preview this layer with openlayers, everyting is fine starting at scale of 1 : 35M. However, when I zoom out, objects just dissapear. I had the style set to Point, so polygons being too small should not be the issue.

Currently I have a FeatureTypeStyle which uses PointSymbolizer with <MinScaleDenominator>10000000</MinScaleDenominator> and PolygonSymbolizer with <MaxScaleDenominator>10000000</MaxScaleDenominator>, and I've tried using only PointSymbolizer with the same result.

Geoserver version is 2.8.0.

What might be the problem here?

  • 2
    do you have Support on the fly geometry simplification turned on for the store? – Ian Turton Nov 12 '15 at 13:57
  • @iant wow, that was fast. I actually did. removing it solved the issue. thanks for the prompt reply! – Vladimir Nov 12 '15 at 14:03
4

There are still some issues with the PostGIS on the fly simplification sometimes. So the quick answer is to turn it off for now and see if the issue goes away.

For bonus marks if you can isolate the Polygon(s) that cause the issue and raise a bug report with them attached so it gets fixed.

  • 2
    The issues are on the postgis side, it seems that a new function was added to the latest version of postgis that we could use instead of st_simplify, that should not have this problem – Andrea Aime Nov 12 '15 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.