4

For my layers none of the QGIS geoproccesing tools (difference, intersection, etc. all give empty attribute tables) work, though I've checked for all (?) error sources (as in the title). Then I tried to do a manual edit of my polygon-geometry (adding a ring) and this is what happend (the data is in my Dropbox): enter image description here

I'm using QGIS 2.10.0 on Win7

4
  • I get the same result in QGIS 2.10 Pisa. Very strange. Commented Nov 13, 2015 at 13:46
  • Thanks for trying! ..there must be something wrong with the geometry..
    – Kay
    Commented Nov 13, 2015 at 13:51
  • What kind of output are you wanting to achieve? Is it only an intersection of the 2 layers or something else?
    – Joseph
    Commented Nov 13, 2015 at 13:56
  • Actually I want a difference operation with the other layer (the small blue polygons).
    – Kay
    Commented Nov 13, 2015 at 14:00

1 Answer 1

4

There's an issue with your "mair_dxf" layers. From the metadata, it reads that there's 3 features whereas in the Attribute Table, it only reads 2 features.

To rectify this, re-save the layer as a new shapefile. The metadata should read 2 features now, run the Difference tool again:

Result

Hope this helps!


Edit:

Turns out that there is an issue with QGIS 2.10 where the layers fail to be processed correctly. However, the layers work fine in QGIS 2.8.2 and 2.12.0 where I was also able to add rings successfully:

Rings added

6
  • This was looking hopeful - but I did exactly as proposed (Metadata in new file says 2 features) - but the same result as before.. Attribute table of newly created shape is empty! ...I'd be very interested if you can reproduce the error when trying to add a ring? Could you do that for me? Many thanks!
    – Kay
    Commented Nov 13, 2015 at 14:20
  • @Kay - Weird, I cannot reproduce your error. I was able to add rings fine. I'm using QGIS 2.12, will test this on 2.10 and see if the error can be reproduced :)
    – Joseph
    Commented Nov 13, 2015 at 14:24
  • 1
    @Kay - Now this is funny, I can reproduce the error in QGIS 2.10. It works perfectly fine in 2.12-0 and 2.8.2. Think it might be time to upgrade your QGIS (or downgrade!) :)
    – Joseph
    Commented Nov 13, 2015 at 14:32
  • 2
    Joseph, many thanks - you saved my day (thought I'm going nuts!) However, it is very awkard that this issue wasn't noticed/looked for earlier! Would you please add this to the answer - then I will check it!
    – Kay
    Commented Nov 13, 2015 at 16:20
  • @Kay - Haha, I'm already nuts working with GIS! Edited the post, hope you got the results you're looking for :)
    – Joseph
    Commented Nov 16, 2015 at 10:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.