1

I'm trying to calculate the slope for a raster layer using ArcMap 10.2 and the Slope (Spatial Analyst) function. The raster I'm using is an NED 10m mosaic DEM, and the mosaic's datum is in WGS 1984. I am trying to calculate the degree slope, but my numbers are wonky. I know the output shapefile for the slope is incorrect because, according to these calculations, known flat areas have a slope of 71.9 - 89.9 degrees. My Z factor is 1 currently. I've tried reprojecting my DEM to NAD 1983 (2011) and change the Z factor, but I got the same results. Does anyone know what the problem I'm encountering is, and if so, how do I fix it?

One thing to note: I noticed my mosaic does not have an established Linear Unit (Layer Properties > Source > Spatial Reference (scroll)), which I found odd. Not sure if that ties into my problem or not, but I figured I'd mention it.

1

It's not because there's no linear unit, but that's a symptom of what's going on. You need to put your data in a projected (i.e., Cartesian) coordinate system; in WGS84 or NAD83 it's in a geographic (i.e., angular) system. One degree of lat/long change is not the same everywhere, and the equivalent distance in the vertical z values coded in the raster is typically very much larger than the actual feet or meters the DEM actually encodes. The calculations you're currently asking ArcGIS to do don't make any sense, though Arc doesn't actually warn you of this :)

First, reproject the DEM (http://resources.arcgis.com/EN/HELP/MAIN/10.1/index.html#//00170000007q000000) to a coordinate system that makes sense for your area of interest, ideally something equal-area (e.g., Albers Equal Area conic, a UTM zone, a US State Plane zone, etc.). Be sure to use either a bilinear (good) or cubic (better, just takes longer) resampling scheme, since DEMs represent continuous fluctuation in the z elevation values. Then calculate a slope raster on that.

  • Thank you for commenting! Unfortunately, I'm still encountering a weird slope output. I tried two different projected coordinate systems (UTM zone and Albers, with cubic resampling technique) with my DEM so see if the output would change, but it didn't. Reprojecting my DEM did solve my unit problem, however, so thank you for that. I'm looking at my DEM's layer properties to see if I'm missing any more data, but nothing appears out of the ordinary. Any ideas? – Tula Nov 15 '15 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.